3.8.3 cannot compile the simulator on macOS

paltform: mac mini M2, macos 14.4.1, xcode 15.4

According to the manual Engine Customization, I did the following:

I fetched the 3.8.4 branch code from GitHub, then in the engine root directory, I ran npm install.

After that, I went to the native directory and ran npm install and gulp init.

Next, I ran gulp gen-simulator.

❯ gulp gen-simulator                                                                                                                                                                                                                 ─╯
[06:07:06] Using gulpfile /Volumes/idea/cc/engines/3.8/native/gulpfile.js
[06:07:07] Starting 'gen-simulator'...
remove old simulator project

make project
-- The CXX compiler identification is unknown
CMake Error at CMakeLists.txt:4 (project):
  No CMAKE_CXX_COMPILER could be found.
-- Configuring incomplete, errors occurred!
cmake finished!
build project

2024-05-18 06:07:10.960 xcodebuild[951:10983437] Writing error result bundle to /var/folders/wj/1cs10q7j7jq_dt3334gbyvtr0000gn/T/ResultBundle_2024-18-05_06-07-0010.xcresult
xcodebuild: error: 'SimulatorApp.xcodeproj' does not exist.
cmake finished!
[06:07:12] Finished 'gen-simulator' after 5.06 s

The output result indicates that SimulatorApp.xcodeproj could not be found.

I would like to ask the seniors for the correct procedure, thank you.

I tried again today and found that it could actually find the CXX compiler…

I am not sure of the reason, but I did use xcodebuild to build other projects in the past few days. Maybe that was it…

In any case, if someone else encounters the same issue, check your environment first to see if other projects can compile normally.

That’s it.