About Asset Bundle Errors

To use an asset bundle, run BuildBundle.
This looks fine, but when I press the “Confirm” button after the build is complete, I get a Notifications as if the build degree failed.

However, it does not say what exactly the error is or what the cause of the error is, so I cannot solve this problem.

The version of Cocos Creater is 3.8.2.
I have 100 GB of free space on my PC.
This error occurs 100% of the time after following the same procedure to BuildBundle and pressing Confirm.

What is the cause of this error?

It has been fixed by CocosCreator 383, please use 3.8.3 to build bundle.

1 Like

Thank you!
Is that information listed anywhere?
For example, I didn’t see it listed in the 3.8.3 update on the following page

Moving from 3.8.2 to 3.83 is risky, so I am wondering if I need to upgrade because of this error!

  1. I have been told by our Cocos colleague. It dont list in the update Page.
  2. You can upgrade from 3.8.2 to 3.8.3 for opening the project with 3.8.3 engine, normally it will upgrade smoothly, in case of any risk you can back up your project.
1 Like

Thank you very much.
If you ever meet with your colleagues at Cocos, please ask them to add an update info


there is a fixed info showed in the 383 released note. Please check the information in the link https://www.cocos.com/en/creator-download

1 Like

Generally, upgrade projects from 3.8.2 to 3.8.3 will be very smooth, just be careful if you customize shaders based on builtin-unlit.effect.

The parameters of CalculatePlanarShadowClipPos used in builtin-unlit.effect has been changed.

If you encounter shader compilation errors, please check this, and it will easily be fixed by referring to the builtin-unlit.effect in the internal assets.

Plus, It’s best to back up your project before upgrading.